Route Redistribution an Overview and Configuration
Route Redistribution is, where the routes are advertised
from one routing protocol to another routing protocol. Route Redistribution supports the proprietary protocol, legacy equipment, or that merged
with other networks using a different routing protocol.
How to Configure Route Redistribution with different Routing Protocols
Route Redistribution |
Router> enable
Router# configure
terminal
Enter configuration
commands, one per line. End with CNTL / Z.
Router
(config) # hostname R1
R1
(config) # interface serial 0/1/0
R1 (config-if) # ip
address 1.0.0.1 255.0.0.0
R1 (config-if) #clock
rate 64000
R1 (config-if) #keepalive
12
R1 (config-if) #no
shutdown
%LINK-5-CHANGED:
Interface Serial0/1/0, changed state to down
R1 (config-if) #exit
R1
(config) # interface fastethernet0/0
OR
R1
(config) # int fa0/0
R1 (config-if) # ip
address 192.168.1.100 255.255.255.0
R1 (config-if) #no
shutdown
Interface Status up |
R1 (config-if) #exit
R1
(config) # ip dhcp pool ABC
R1 (dhcp-config) # default-router
192.168.1.100
R1 (dhcp-config) # network
192.168.1.0 255.255.255.0
R1 (dhcp-config) # end
R1#
Router> enable
Router# configure
terminal
Enter configuration
commands, one per line. End with CNTL / Z.
Router
(config) # hostname R2
R2 (config) # interface
serial 0/1/0
R2 (config-if) # ip
address 1.0.0.2 255.0.0.0
R2 (config-if) #keepalive
12
R2 (config-if) #no
shutdown
Interface Status up |
R2 (config-if) #exit
R2
(config) # interface serial 0/1/1
R2 (config-if) # ip
address 2.0.0.1 255.0.0.0
R2 (config-if) #clock
rate 64000
R2 (config-if) #keepalive
12
R2 (config-if) #no
shutdown
%LINK-5-CHANGED:
Interface Serial0/1/1, changed state to down
R2
(config) # interface fastethernet0/0
OR
R2
(config) # int fa0/0
R2 (config-if) # ip
address 192.168.2.100 255.255.255.0
R2 (config-if) #no
shutdown
Interface Status up |
R2 (config-if) #exit
R2
(config) # ip dhcp pool ABC
R2 (dhcp-config) # default-router 192.168.2.100
R2 (dhcp-config) #
network 192.168.2.0 255.255.255.0
R2 (dhcp-config) # end
R2#
Router> enable
Router# configure
terminal
Enter configuration
commands, one per line. End with CNTL / Z.
Router
(config) # hostname R3
R3
(config) # interface serial 0/1/1
R3 (config-if) # ip
address 2.0.0.2 255.0.0.0
R3 (config-if) #keepalive
12
R3 (config-if) #no
shutdown
Interface Status up |
R3 (config-if) #exit
R3
(config) # interface fastethernet0/0
OR
R3
(config) # int fa0/0
R3 (config-if) # ip
address 192.168.3.100 255.255.255.0
R3 (config-if) #no shutdown
Interface Status up |
R3 (config-if) #exit
R3
(config) # ip dhcp pool ABC
R3 (dhcp-config) # default-router 192.168.3.100
R3 (dhcp-config) #
network 192.168.3.0 255.255.255.0
R3 (dhcp-config) # end
R3#
R1#
show ip route
IP Route Status |
R1#
Note:
By default, in the router R1 routing table the two associated interfaces and
directly connected networks are listed.
Router R2
R2#
show ip route
IP Route Status |
R2#
Note:
By default, in the router R2 routing table the three associated interfaces and
directly connected networks are listed.
Router R3
R3#
show ip route
IP Route Status |
R3#
Note:
By default, in the router R3 routing table the two associated interfaces and
directly connected networks are listed.
Router R1
R1# configure terminal
R1
(config) #router eigrp 5
R1 (config-router) #network 192.168.1.0
R1 (config-router) #network 1.0.0.0
R1 (config-router) #end
R1#
Router R2
R2# configure terminal
R2
(config) #router eigrp 5
R2 (config-router) #network 192.168.2.0
R2 (config-router) #network 1.0.0.0
%DUAL-5-NBRCHANGE: IP-EIGRP 5: Neighbor
1.0.0.1 (Serial0/1/0) is up: new adjacency
R2 (config-router) #no auto-summary
R2 (config-router) #exit
Router R2
R2 (config) #router rip
R2 (config-router) #version 2
R2 (config-router) #network 2.0.0.0
R2 (config-router) #no auto-summary
R2 (config-router) #end
R2#
Router R3
R3# configure terminal
R3
(config) #router rip
R3 (config-router) #version 2
R3 (config-router) #no auto-summary
R3 (config-router) #network 192.168.3.0
R3 (config-router) #network 2.0.0.0
R3 (config-router) #end
R3#
Router R1
R1#
show ip route
IP Route Status |
R1#
Router R2
R2#
show ip route
IP Route Status |
R2#
Router R3
R3#
show ip route
IP Route Status |
R3#
R2#configure terminal
R2
(config) #router eigrp 5
R2 (config-router) #redistribute rip metric 1 1 255
255 1
R2 (config-router) #exit
R2
(config) #router rip
R2 (config-router) #redistribute eigrp 5 metric 1
R2 (config-router) #end
R2#
Router R1
R1#
ping 192.168.3.1
Successful Ping Verification |
R1#
ping 192.168.2.1
Successful Ping Verification |
R1#
Router R2
R2#
ping 192.168.3.1
Successful Ping Verification |
R2#
ping 192.168.1.1
Successful Ping Verification |
R2#
Router R3
R3#
ping 192.168.1.1
Successful Ping Verification |
R3#
ping 192.168.2.1
Successful Ping Verification |
R3#
R2#
show ip protocols
IP Protocol Status |
IP Protocol Status |
R2#
Search
Tags
- What is route redistribution in CCNA
- What is route redistribution in OSPF
- What is route configuration
- Redistribution in networking
If you want to configure and Practical Lab of Static and Dynamic Routing then visit below link: 👇
How to Configure Static Routing
Dynamic Routing
How to Configure OSPF Multi-area
How to Configure OSPF Single-area
0 Comments